PrintQueueWatch_2_0_8_Beta stop working

Sep 25, 2012 at 1:32 PM

I've been working with PrintQueueWatch_2_0_8_Beta in w7 to 64 bit and everything was working properly but suddenly events jobadded and jobset stopped working ....
I have reviewed the code several times and can not find the reason...
I want to know if this happened to you and if you have been able to determine the reason ...

Coordinator
Sep 25, 2012 at 8:52 PM

I've not seen that but have had issues with 64 bit code in general - what issues are you seeing?  Any stack trace or exception text available?

Sep 26, 2012 at 12:43 PM

that's the problem the program run fine no errors but don't capture any event from the priters....


Sep 26, 2012 at 8:17 PM

I have seen the same thing happen today. In application compiled in 32-bit the JobAdded event triggers fine but not in 64-bit or AnyCPU. I have also tried to find the cause of it but found nothing. The JobAdded event is registered successfully in any of the latter cases. I havent got a clue why thought, no errors available either to indicate why.

Sep 27, 2012 at 4:54 PM
Edited Sep 27, 2012 at 5:31 PM
well I've found a partial solution!!!!!
I was compiling x64 because the target plataform to deploy my project and I had thought that a program to run in 64 bit system must be copiling in x64 or any cpu, however testing I change the target plataform to x86 and in project ->MyProjectName Properties->Build  I put all in x86 too and finally the program run in 64 bit and the events functions work exelent capturing all events....tha's what I need ....
I don't care if the .exe is compiling in x86 or x64 if it run in w7 64 and the library capture the printjobs event...
I wish that merrion comment something about this......and apologize about my english.